Buttons disabled for no apparent reason

I have a strange problem where I have some buttons(within the crudIconGroup) becoming disabled(no click animation or anything) when I add an AbsoluteLayout(itemNavLayout) next to the AbsoluteLayout(iconGroupLayout) that contains them. They do not overlap. Here are the relevant bits of my code:

private void setupLayouts(){
borderLayout = new BorderLayout();
displayLayout = new AbsoluteLayout();
iconGroupLayout = new AbsoluteLayout();
innerDisplayLayout = new AbsoluteLayout();
crudIconGroup = new CRUDIconGroup();
headerArea = new HeaderArea();
footerArea = new FooterArea();
linkArea = new LinkArea();
itemNavLayout = new AbsoluteLayout();

private void setupHomeView(){
borderLayout.addComponent(headerArea, BorderLayout.Constraint.NORTH);
borderLayout.addComponent(footerArea, BorderLayout.Constraint.SOUTH);
borderLayout.addComponent(displayLayout, BorderLayout.Constraint.CENTER);
displayLayout.addComponent(iconGroupLayout, “left: 70%; top: 0%;”);
displayLayout.addComponent(linkArea, “top: 0%; left: 0%;”);
iconGroupLayout.addComponent(crudIconGroup, “top: 0%; right: 5px;”);
//buttons work whenever the statement below is commented out
displayLayout.addComponent(itemNavLayout, “top: 0px; left: 201px;”);
displayLayout.addComponent(innerDisplayLayout, “top: 21px; left: 201px;”);
[/code]All of the Buttons in the linkArea work, as well as the ones in the header regardless of whether or not the itemNavLayout is present. The crudIconGroup buttons don’t, but I also made a fairly simple button and added it to the iconGroupLayout, and it didn’t work much like the ones within the crudIconGroup(though it did when itemNavLayout was commented out). All of the buttons within the linkArea and the crudIconGroup do essentially the same thing, which is add a component to the innerDisplayLayout and were all working before.

I tried running the Eclipse debugger and added breakpoints in the ClickListener, but they don’t get reached when I try clicking. Is there anything else I should be looking at or trying? I’m running out of ideas, and this just seems completely random.

I tried checking, and they are enabled, they just don’t do anything when the layout is present.

I simply switched the order that I added the components such that I added the itemNavLayout before the iconGroupLayout and it worked. Is there any reason that it worked this way and not the other?