Build fails with Vaadin 7.7

It seems like perhaps the Jar in the repo is bad… ( my build works fine if I change back to 7.6.8)

diagnostic: /home/rsutton/.m2/repository/com/vaadin/vaadin-server/7.7.0/vaadin-server-7.7.0.jar(com/vaadin/server/ error: cannot access com.vaadin.annotations.JavaScript
import com.vaadin.annotations.JavaScript;
bad source file: /home/rsutton/.m2/repository/com/vaadin/vaadin-server/7.7.0/vaadin-server-7.7.0.jar(com/vaadin/annotations/
file does not contain class com.vaadin.annotations.JavaScript
Please remove or make sure it appears in the correct subdirectory of the sourcepath.
error on execute: error during compilation


Total time: 2.136s
Finished at: Thu Sep 15 16:00:37 AEST 2016
Final Memory: 28M/429M

Failed to execute goal org.bsc.maven:maven-processor-plugin:2.2.4:process (process) on project VaadinUtils: Error executing: error during compilation → [Help 1]

Have you tried removing the file from your local maven cache so that Maven downloads it again?

tried clearing the m2 cache of vaadin things, didn’t help