14.0.0.alpha4 - Grids not loading; ItemCache is undefined and $0.$connector


I have a Grid that populates its information using a ListDataProvider. The Grid also contains a filter in the HeaderRow, using similar methodologies found in the Component documentation (https://vaadin.com/components/vaadin-grid/java-examples/filtering).

However, when I run the project (Using Wildfly 15.0.1.Final, deployed as a .WAR in Firefox 66.0.5), the grid does not populate and I keep encountering the following errors:

(TypeError) : ItemCache is undefined
(TypeError) : $0.$connector is undefined

I have also seen other errors on some of my more complex Grid implementations such as

(TypeError) : window.Vaadin.Flow.gridConnector is undefined
(TypeError) : Gestures is undefined

Attached is a sample of the issues I am facing using a basic Grid setup.

Appreciate the help in advance.

I’m having trouble attaching a .zip of the example project, so here is the main class and pom file instead.
17665717.java (2.74 KB)
17665720.xml (5.45 KB)

Also, this still happens in beta1, since that just got released an hour ago as of posting this…

This issue doesn’t appear to affect the example project I attached in Chrome, but the Grid definitely doesn’t populate in Safari (to the point that it completely breaks the browser), and Firefox version 66.0.5. In Chrome version 74.0.3729.131, the basic project works fine, but my other project with more complicated implementations of the Grid will show similar TypeErrors:

(TypeError) : Cannot read property 'initLazy' of undefined
(TypeError) : Cannot read property 'reset' of undefined
(TypeError) : Cannot read property 'setSelectionMode' of undefined
(TypeError) : Cannot read property 'setColumnId' of undefined

But then the Grid will load normally if I refresh the page.

I’m getting similar type of errors when I tried to migrate to beta1 as well. I’m using a TreeGrid.

Chrome version: Version 74.0.3729.157 (Official Build) (64-bit). Firefox 66.0.5

I’m also getting a “Maven Java EE Configruation Problem: An error occurred while filtering resources”

Any ideas?

It’s a known problem, please have a look at this issue (there’s also a workaround): https://github.com/vaadin/flow/issues/5696