Loading...
Important Notice - Forums is archived

To simplify things and help our users to be more productive, we have archived the current forum and focus our efforts on helping developers on Stack Overflow. You can post new questions on Stack Overflow or join our Discord channel.

Product icon
TUTORIAL

Vaadin lets you build secure, UX-first PWAs entirely in Java.
Free ebook & tutorial.

Can't run vaadin 7 project with ivy/eclipse

Rodrigo Souza
9 years ago Aug 13, 2013 11:38am
Marius Reinwald
9 years ago Aug 13, 2013 11:46am

Try replacing your servlet-api dependency with either

<dependency org="javax.servlet" name="javax.servlet-api" rev="3.0.1"/>

or

<dependency org="javax.servlet" name="javax.servlet-api" rev="3.1.0"/>

which can be found here. If you need the tomcat one you can find it here.

Rodrigo Souza
9 years ago Aug 13, 2013 12:30pm
Marius Reinwald
9 years ago Aug 13, 2013 12:35pm
This

should give you an idea how you can map your widgetset, servlet,.... using the WebServlet annotation or the web.xml.

Rodrigo Souza
9 years ago Aug 13, 2013 12:54pm
Gavaskar Rathnam
7 years ago Feb 19, 2016 9:27am