Loading...
Important Notice - Forums is archived

To simplify things and help our users to be more productive, we have archived the current forum and focus our efforts on helping developers on Stack Overflow. You can post new questions on Stack Overflow or join our Discord channel.

Product icon
TUTORIAL

Vaadin lets you build secure, UX-first PWAs entirely in Java.
Free ebook & tutorial.

Overriding Theming and Stylling for Grid won't work?

Alisa Lee
5 years ago Nov 02, 2016 6:51pm
Anatoly Shirokov
5 years ago Nov 02, 2016 9:04pm
Alisa Lee
5 years ago Nov 02, 2016 9:42pm
Marco Collovati
5 years ago Nov 02, 2016 9:59pm

Have you tried with 

.v-grid-test .v-grid-cell { ... }

If this does not work try add !important flag to the css rules

Even better if nested in your scss theme mixin

HTH
Marco
 

Anatoly Shirokov
5 years ago Nov 02, 2016 10:09pm

Alisa Lee: It didn't change anything, unfortunately. I even compiled the theme but I don't know if that makes a difference.

 

Try to clear browser cache before testing. I have tested the following:

@import "../valo/valo.scss";

@mixin mytheme {
@include valo;

// Insert your own theme rules here
.v-grid-test {
.v-grid-row > td {
color : white;
background : red;
line-height : 15px;
}
}
}

As you can see it works:

Anatoly Shirokov
5 years ago Nov 04, 2016 10:26am
Alisa Lee
5 years ago Nov 04, 2016 6:11pm
Alisa Lee
5 years ago Nov 04, 2016 9:50pm
Alisa Lee
5 years ago Nov 07, 2016 10:10pm
Anatoly Shirokov
5 years ago Nov 08, 2016 5:59am

Alisa, try the following:

.mytheme .v-grid-test .v-grid-header .v-grid-column-header-content, 
.mytheme .v-grid-test .v-grid-header .v-grid-row > th {
           line-height : 15px;
}

Warning! Before testing clear browser cache!