Loading...
Important Notice - Forums is archived

To simplify things and help our users to be more productive, we have archived the current forum and focus our efforts on helping developers on Stack Overflow. You can post new questions on Stack Overflow or join our Discord channel.

Product icon
TUTORIAL

Vaadin lets you build secure, UX-first PWAs entirely in Java.
Free ebook & tutorial.

Production Mode in Vaadin Spring-Boot

Jonas Hahn
6 years ago Sep 26, 2015 3:48pm
Kim Leppänen
6 years ago Sep 28, 2015 10:09am
Petter Holmström
6 years ago Sep 29, 2015 5:14am

If you are using Spring Boot, you can set most (but not all) of the servlet properties by adding them to your application.properties file. You can find the supported properties here. In your case, you'd use:

  • vaadin.servlet.resourceCacheTime
  • vaadin.servlet.productionMode
  • vaadin.servlet.heartbeatInterval
  • vaadin.servlet.closeIdleSessions
Matti Tahvonen
6 years ago Sep 29, 2015 7:58am
Jonas Hahn
6 years ago Sep 30, 2015 8:49pm
Michael Benz
5 years ago Feb 09, 2017 8:40am
peter voland
3 years ago Sep 30, 2018 4:37am
Mark Donahue
3 years ago Oct 03, 2018 9:30pm
peter voland
3 years ago Oct 07, 2018 6:06pm
peter voland
3 years ago Oct 08, 2018 1:33am
Mark Donahue
3 years ago Oct 08, 2018 9:13pm
mark snijder
3 years ago Jan 07, 2019 11:59am

peter voland: sorry to sound weird but... I am using SpringBoot and I have no idea where an yml file could be... I am using maven and springboot, (yml this looks like gradle? I am not using gradle ) I have tried in application.properties

#vaadin.servlet.resourceCacheTime
vaadin.servlet.productionMode=true
#vaadin.servlet.heartbeatInterval
vaadin.servlet.closeIdleSessions=true;

in vain

I got it to work by changing vaadin.servlet.productionMode=true to vaadin.productionMode=true

Rafal Kozyra
3 years ago Feb 18, 2019 7:35pm
Markus O.
3 years ago Feb 25, 2019 6:04am

Rafal Kozyra: I tried everything from this topic to run application in production mode... but all the time I see DEBUG MODE. Any chance for help?

Try setting

vaadin.productionMode=true
vaadin.heartbeatInterval=60
vaadin.closeIdleSessions=true

in application.properties. Then build with

mvn clean package -Pproduction-mode
Last updated on Feb, 25th 2019
Rafal Kozyra
3 years ago Feb 26, 2019 9:53am