Widgetset error while migrating to v7 compatibility mode

Hi,

I’m migrating Vaadin 7 application to Vaadin 8 while keeping old code in compatibility mode. I followed this link: https://vaadin.com/docs/v8/framework/migration/migrating-to-vaadin8.html

All the code has been migrated to compatible mode, and the application is up and running. But I’m getting this error message related to Widgetset in bottom of every page:

Widgetset ‘com.vaadin.v7.Vaadin7WidgetSet’ does not contain an implementation for com.abc.def.WindowEvent.WindowEvent. Check the connector’s @Connect mapping, the widgetset’s GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions.

Windowevent is the custom widgetset.
Kindly guide me to resolve this error.

Windowevent is the custom widgetset. Kindly guide me to resolve this error.

While you have faithfully copied needed changes according to documentation, you have probably removed your custom widgetset from your application widgetset.gwt.xml file, or something similar.

Here is my *_Widgetset.gwt.xml file. It has entry of windowsevent widgetset:
`

<inherits name="com.vaadin.DefaultWidgetSet" />
<inherits name="com.vaadin.lazyloadwrapper.widgetset.LazyLoadWrapperWidgetset" />
<inherits name="com.abc.def.WindowEvent.widgetset.WindowEventWidgetset" />
<inherits name="com.vaadin.v7.Vaadin7WidgetSet" />
`