Widgetset does not contain implementation

Hello all,

I am having a serious issue getting add-ons working with my Vaadin project. Here is the message I get regardless of client-side add-on I use:

Widgetset does not contain implementation for Check its @ClientWidget mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions. Unrendered UIDL:

They were working just fine until I added persistence with a postgres database… although I’m not even sure that’s the problem. Here are the addons currently in my lib folder:

animator.jar
appfoundation.jar
eclipselink-jpa-modelgen_2.1.0.v20100614-r7608.jar
eclipselink.jar
javax.persistence_1.0.0.jar
javax.persistence_2.0.1.v201006031150.jar
notifique-1.0.3.jar
overlays-0.9.8.jar
persistence.jar
postgresql-8.4-701.jdbc4.jar
refresher-1.0.0.jar
vaadin-6.4.2.jar

Now, I know it’s not add-on specific because I tried getting ICEPush to work instead of Refresher (at first I thought it was a problem with Refresher) but even that did not work. I then tried implementing Notifique and that ALSO did not work, giving me the same problem. I let the Vaadin plugin compile my widgetset for me, and here is what it looks like currently:

<?xml version="1.0" encoding="UTF-8"?>
<!--
 Uncomment the following to compile the widgetset for one browser only.
 This can reduce the GWT compilation time significantly when debugging.
 The line should be commented out before deployment to production
 environments.
  
 Multiple browsers can be specified for GWT 1.7 as a comma separated
 list. The supported user agents at the moment of writing were:
 ie6,ie8,gecko,gecko1_8,safari,opera
 
 The value gecko is used for Firefox 3 and later, gecko1_8 is for
 Firefox 2 and safari is used for  webkit based browsers including
 Google Chrome.
-->
<set-property name="user.agent" value="gecko"/>

<inherits name="org.vaadin.henrik.refresher.RefresherApplicationWidgetset" />

<inherits name="org.vaadin.artur.icepush.IcepushaddonWidgetset" />

<inherits name="org.vaadin.jouni.animator.AnimatorWidgetset" />

<inherits name="org.vaadin.notifique.widgetset.NotifiqueWidgetset" />

<inherits name="org.vaadin.overlay.OverlaysWidgetset" />

Any ideas? Everything used to work just fine and I have had no trouble with add-ons in the past. Thanks in advance for any assistance.

There are some JARs that the GWT compiler chokes on, independent of whether used with Vaadin or not, and I have the vague recollection the postgres JDBC4 driver JAR might be one of them. I’m not sure if any of the other JARs cause problems, some Hibernate JARs might. I don’t know why this happens.

You might need to remove the JDBC driver from the classpath used by the widgetset compiler in one way or another when compiling the widgetset. Unfortunately, the Vaadin Eclipse plugin does not provide fine-tuning possibilities as for which JARs to exclude, so you probably either need to remove them by hand from your classpath for the time you compile the widgetset, or use some other mechanism (such as an ANT script) for compiling the widgetset so that those JARs are excluded from the classpath.

Is it enough to simply remove the jars from the lib folder? If so, I have done that and I still have issues. I’m now concerned that it may be the Refresher Addon that’s causing the problem. I have removed all jars except for Vaadin and Refresher and I have the same issue. I’m currently using Vaadin 6.4.2.

EDIT: To clarify, if I also don’t use any code from any of the jars I have imported but keep the jars I have no issue. I just tested by removing Refresher and putting back Overlays and Notifique and I am having the same problem.