Widgetset Compilation Failure

When running the latest eclipse experimental build the following mismatch in widgetset versions is reported.

Warning: widgetset version 9.9.9.INTERNAL-DEBUG-BUILD does not seem to match theme version 7_0_0_nightly-dec9f9......

If I attempt to recompile the widgetset I get a NPE

!ENTRY com.vaadin.integration.eclipse 4 0 2012-10-12 00:26:59.818
!MESSAGE Widgetset compilation failed
	at com.vaadin.integration.eclipse.handlers.CompileWidgetsetHandler$1.run(CompileWidgetsetHandler.java:92)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

Is this expected behaviour for the current beta?

The first issue is

The second problem you are seeing is not normal. Please try to upgrade to the latest version of the eclipse plug-in from the update site http://vaadin.com/eclipse/experimental and retest. If the problem persists, more information about your Eclipse version, project setup etc. is probably needed.

The second problem seems to have resolved itself.

At the time I tried multiple times to clean the project, recompile the widgetset, restart eclipse, etc. all without success.

Those attempts were with the stock Hello World for Vaadin 7 application. This morning I tried porting my own very basic application and the widgetset compiled OK. Went back and tried again with Hello World and it too now compiles OK. Didn’t update any plugins but have rebooted the computer in between.

Will put it down to gremlins and move on.

Thanks for your response.

The second problem has returned!!!

I was attempting to debug into the Vaadin source and it appeared to be out of sync. i.e., breakpointing on comments etc.

The source libraries were pointing to JAR files in what appears to be an IVY cache so I used the options on the eclipse project to clear the cache and resolve IVY dependencies. Didn’t help and the source and binaries are still out of sync.

Thought I’d recompile widget set just in case and got the aforementioned NPE again.

Reran eclipse software update, cleared IVY caches and still get NPE on widget recompile?

I probably don’t have a full understanding on what needs to be refreshed when the version 7.0 plugin is updated.

Sorted out the source/binary discrepancy. Had the AddressBook tutorial (Vaadin 6 version) deployed on the same server and Tomcat was using the 6.0.8rc1 source for the Vaadin 7 application JARs. undeployed the Vaadin 6 app and source/binary now match.

NPE on widget compilation still there so these two issues were most likely unrelated. Still no idea on the widget compilation though suspect has something to do with IVY dependency resolution?