Widget set problem

I have used the ICEPush widget in one of my projects before without a problem. I have just started a new program, and this one doesn’t seem to want to load ICEPush.
I get the following on my browser when I run the program:


Widgetset does not contain implementation for org.vaadin.artur.icepush.ICEPush. Check its @ClientWidget mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions. Unrendered UIDL:
-Unrendered UIDL
-org.vaadin.artur.icepush.ICEPush(NO CLIENT IMPLEMENTATION FOUND) id=PID15 pushGroup=ICEPush-1 codeLocation=/JART_Test/code.icepush

I have recompiled my widgeset (I think) using Eclipse. The console output looks like this:


Compiling widgetset com.verisign.jart.widgetset.JartWidgetset
Updating GWT module description file...
Jul 16, 2012 9:33:07 AM com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
INFO: Widgetsets found from classpath:
	com.vaadin.terminal.gwt.DefaultWidgetSet in jar:file:/app/VRSN/Software/Eclipse/WS/JART/JART/WebContent/WEB-INF/lib/vaadin-6.8.1.jar!/
	org.vaadin.aboutbox.AboutboxWidgetset in jar:file:/app/VRSN/lib/Vaadin/aboutbox-1.0.0.jar!/
	com.verisign.jart.widgetset.JartWidgetset in file:/app/VRSN/Software/Eclipse/WS/JART/JART/src
	org.vaadin.artur.icepush.IcepushaddonWidgetset in jar:file:/app/VRSN/lib/Vaadin/icepush-0.2.1.jar!/
	com.vaadin.addon.timeline.gwt.TimelineWidgetSet in jar:file:/app/VRSN/lib/Vaadin/vaadin-timeline-cval-2.0-1.2.4.custom.jar!/
	com.github.wolfie.sessionguard.SessionguardWidgetset in jar:file:/app/VRSN/lib/Vaadin/sessionguard-0.0.5.jar!/
	com.vaadin.addon.colorpicker.gwt.ColorPickerWidgetSet in jar:file:/app/VRSN/lib/Vaadin/vaadin-colorpicker-1.1.1.custom.jar!/

Jul 16, 2012 9:33:07 AM com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
INFO: Search took 7ms
Done.
Starting GWT compiler
Jul 16, 2012 9:33:33 AM com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getPaintablesHavingWidgetAnnotation
INFO: Searching for paintables..
Jul 16, 2012 9:33:34 AM com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getPaintablesHavingWidgetAnnotation
INFO: Search took 1007ms
Widgetset compilation completed

Can someone give me a hint as to what I’m doing wrong here?

thanks,

nbc

I found another thread discussing this problem, and it appears that for some reason, my web.xml file did not have a section dedicated to the widgetset. I’m not sure why this was not created automatically by Eclipse for this project, but I manually added that section, and the problem appears to be solved…

The other thread can be found here…


https://vaadin.com/forum/-/message_boards/view_message/429047

nbc