Webpack error: highcharts

Greetings. I’ve been getting the below error for a while now, which is preventing my ui from loading when I run my webapp locally. Seems to have something to do with a loader not able to process the highcharts-more.js file. The package.json and webpack.config.js appear to be automated through vaadin so I’m not sure how I can fix this. This error first appeared after upgrading from 14.8.3 to 14.9.6 in the pom. Currently I’m on 14.10.10. Is this a bug, or is there something I can do to fix this?

2023-12-17T15:00:40.415Z ERROR 41592 --- [ webpack] dev-webpack : ERROR in ../node_modules/highcharts/highcharts-more.js 7:6971 2023-12-17T15:00:40.415Z ERROR 41592 --- [ webpack] dev-webpack : Module parse failed: Unexpected token (7:6971) 2023-12-17T15:00:40.415Z ERROR 41592 --- [ webpack] dev-webpack : You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders 2023-12-17T15:00:40.415Z ERROR 41592 --- [ webpack] dev-webpack : | * 2023-12-17T15:00:40.415Z ERROR 41592 --- [ webpack] dev-webpack : | * License: www.highcharts.com/license 2023-12-17T15:00:40.419Z ERROR 41592 --- [ webpack] dev-webpack : > */!function(t){"object"==typeof module&&module.exports?(t.default=t,module.exports=t):"function"==typeof define&&define.amd?define("highcharts/highcharts-more",["highcharts"],function(e){return t(e),t.Highcharts=e,t}):t("undefined"!=typeof Highcharts?Highcharts:void 0)}(function(t){"use strict";var e=t?t._modules:{};function i(t,e,i,s){t.hasOwnProperty(e)||(t[e]=s.apply(null,i),"function"==typeof
image.png

Looking at the error message, I can see Highcharts 11.2.0 - this version is not used within Vaadin Charts, therefore it is probably not supported. The latest version used by Vaadin is 9.2.2. Possible that the new version of Highcharts is by default not compatible with the used webpack version.

@quirky-zebra You’re exactly right! We removed Vaadin Charts from our pom, but are still using highcharts. Apparently the loader couldn’t parse the newer version of highcharts we were referencing on our backend. Bumping it down, removing config files, rebuilding, and running “pnpm install” appears to have solved the problem. Thanks for your help.

image.png

@quirky-zebra Just for my future reference, where were you able to find the latest version of highcharts for vaadin? I haven’t been able to find that info in the docs or anywhere else.

https://github.com/vaadin/web-components/blob/main/packages/charts/package.json

Great, thanks!