Vaadin Upgrade 7.1.8 to 7.4.5

I’m trying to upgrade the Vaadin version and continue using reindeer theme.

I used Saas Compiler to generate the styles.css, but the output of the css is not matching the expected one. The UI is not rendering because of this issue. While i browse the css as http://localhost:8080/application/VAADIN/themes/mytheme/styles.css

Stylesheet node [BlockNode [.v-assistive-device-only { Rule node [position: Lexical unit node [absolute]
;] Rule node [top: -2000px;]
 Rule node [left: -2000px;]
 Rule node [width: 10px;]
 Rule node [overflow: Lexical unit node [hidden]
;] }] BlockNode [.v-vaadin-version:after { Rule node [content: Lexical unit node ["7.1.8"]
;] }]

The output should be as (from existing application, which is working):

.v-assistive-device-only { position: absolute; top: -2000px; left: -2000px; width: 10px; overflow: hidden; } .v-vaadin-version:after { content: "7.1.8"; }

How to get rid of this blocknode block from css

BlockNode [
...
}]

Thanks

Hi,

Based on you output it looks like your theme jar is still the old 7.1.8. Maybe updating that to 7.4.5 would help?

cheers,
matti

I used the maven based project setting. Using this I could easily upgrade from 7.1.8 to 7.1.15. But the the moment i change the version to a major version, like 7.4.5, it’s not working.

I could see both the versions jar in my lib directory, in case of major version upgrade. But minor version upgrade, it’s working fine.