Vaadin-Portlet in Liferay 7: Failed to load the bootstrap javascript

We are starting a project where a Vaadin-Portlet should be developed for a Liferay server.
Since Liferay has a final release of the 7.x- branch (7.0 CE GA1), we tried to use this version.
But we failed to deploy a simple test-portlet, so that it loads successfully within the Liferay-page.
In the browser we always get the error message:
Failed to load the bootstrap javascript: /o/com.example.Test-Portlet/VAADIN/vaadinBootstrap.js?v=7.6.6

The portlet runs successfully, if we deploy it in a Liferay 6.2. Server (6.2 CA GA5).

We tried to configure the Liferay-Server:
We created a VAADIN folder with the content of vaadin-client-compiled-7.6.6.jar and vaadin-themes-7.6.6.jar in the folder

But we always get the same error-message as posted above.

Thank you very much for your help.


we still found no solution for this problem.
Is there anyone who could give a suggestion?


Hello Yves,

Most likely the reason is double compression of the javascript files. Liferay does gzip for the compressed js-files served by vaadin. You can verify this by checking the loaded js file from browser inspector. Duplicated compression is indicated by not being able to read the downloaded js file (binary inside).

One way to go around this is to extend VaadinServlet and override allowServePrecompressedResource to return false. Then you deploy that servlet to serve resources from /VAADIN folder.

I have been facing similar problems in my previous projects and that did the trick for me. However, my configuration was a little bit different so can not provide you with exact details.

Hello Matti,

thank you very much. That did the trick. It is now working.


Glad to hear that! You are welcome.