Vaadin plugin wrong JRE is used for compiling widgetset

Good day.
Don’t know where to post a bug in Vaading plugin for Eclipse. So…

When I trying to compile a widgetset plugin chooses wrong JRE. It ingores settings from workspace and from project.
Same bug on MacOs and Windows versions.

17406.png