Vaadin Eclipse Integration 1.0 requires Java 5.0 or newer


I am trying to use the Vaadin eclipse plugin but I get the message “Vaadin Eclipse Integration 1.0 requires Java 5.0 or newer” when I try to create a new Vaadin projectvin eclipse.
java version installed on my computer is 1.6.0_15 so it should be ok?

Is there some env var I would be missing?

Should be ok. Please give some more details (os and eclipse versions).

OS : win 7 (eclipse run as admin)
Eclipse: 3.5 (galileo) for web developers

the message appears at the top of the wizard

Apparently your Eclipse/WTP (Web Tools Project) is set up so that there is no Java facet version 5.0 or the Java facet that is selected by default is older than 5.0.

Check if you can select a Java facet version 5.0 (or higher) in New Vaadin Project → Configuration → Modify.
If you are able to select the Java compatibility level 5.0+ in “New Dynamic Web Project”, you should be able to select it for a new Vaadin project as well.

This default selection might be caused by the default Java version you have selected in Eclipse (Preferences → Java → Compiler) or the default JRE selection (Preferences → Java → Installed JREs).

Thanks for your help Henri, I managed to create a Vaadin project.

I had to force the JDK compatibility in Preferences->Java->Compiler to 5.0 (was 6.0) before I select New Vaadin Project.
that’s quite strange, it seems that, on my computer, for the test made in the new project wizard, 6.0<5.0???
The only jre installed on my computer is jre6.