Vaadin components no longer render after update to 14.1.27?

I currently have about 18 different views in the application I’m developing. I decided to update from Vaadin 14.1.18 to 14.1.27 when I added the newest view. After the update, I noticed the login page wasn’t rendering correctly. I tried a mvn clean install which didn’t help. I reverted to 14.1.18 which also didn’t help. I’ve tried deleting target, node_modules, package.json, and package-lock.json which also didn’t help.

I’ve attached a couple of the page views to illustrate what I mean by not rendering correctly. It looks like that only thing rendering on the page is the text that’s the label for some of the components. The first screenshot is the login page. Sign In, Forgot Password, and New User are the labels on the 3 buttons on that page. The labels for the username and password TextFields don’t get rendered. And, of course, nothing else gets rendered either.

About 50 min after I started the app, I got the following message in the terminal which is something I’ve never seen before. Other than that 1 message, there’s no indication that anything has gone wrong. No other warnings or errors.


Unfortunately we can’t see your screenshots.
When you upgrade the application, mvn clean package should be enough. In IntelliJ (if you’re using this IDE), you also have to click on “reload all packages” (in maven).

Do you have an error?
1/ a webpack error in the IDE console when you run the application in development mode.
2/ in the web browser (console error), like a javascript error.

You can also try to package it in production mode, to check if you have an error.

If you downgrade the vaadin application you should remove package*.json, node_modules and target and do the same thing when upgrade the vaadin version. If you haven’t edited package or webpack you can remove them (and target/node_modules) during upgrade/downgrade.That will only make the next build longer.