Vaadin App refuses to start after upgrade to 23.3.0

Just upgrade from 23.2.6 to 23.3.0
Executed vaadin:dance & mvn clean install

I get the following error:

Running Vite to compile frontend resources. This may take a moment, please stand by…

VITE v3.2.4 ready in 3466 ms

Started Vite. Time: 12619ms
➜ Local: http://127.0.0.1:51252/VAADIN/

ERROR(TypeScript) Cannot find module ‘…/…/target/frontend/generated-flow-imports’ or its corresponding type declarations.
FILE C:/intellij_workspace/SQACE/Login/frontend/generated/jar-resources/generated/index.ts:20:25

 18 |
 19 | const { serverSideRoutes } = new Flow({

20 | imports: () => import(‘…/…/target/frontend/generated-flow-imports’)
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
21 | });
22 |
23 | const routes = [

[TypeScript] Found 1 error. Watching for file changes.

File “target/frontend/generated-flow-imports.js” exists.
Any ideas how to solve this? Everything ran fine with 23.2.6

Did you clean up generated resources before you did the update?

deleted them all, no success, same error

Ok i think i understand what the problem is. I have a multi-module project with vaadin components in multiple modules. This seems to cause generated index.ts below generated folder jar-resources, also recursively. For these, import(‘…/…/target/frontend/generated-flow-imports’) cannot succeed as the target does not exist.

@quirky-zebra looks like an ugly vaadin bug to me which prevents me from upgrading, i will create a bug report

Do you have the maven plugin in multiple maven modules?

good hint, i found 2 unnecessary references to the vaadin-maven-plugin. but still the same error.

The recursive “generated” folder now only contains the problematic index.ts and a file named jsdom-exporter-bundle.js. No idea where this is coming from

Weird… never heard of such s problem before even with multiple module projects. The generated folder should only be present in the “wrapper” / Container Project where all your modules are combined to your single jar/war

worked perfectly until 23.3.0 never had issues like these

Is this the same issue? Vaadin 23.3.0 does not work with multi-module projects · Issue #15534 · vaadin/flow · GitHub

Yes it’s the same / cross post of this discussion

Ok, good to have it linked here too if someone happens to find this thread later