Vaadin 7 to 8 Migration - vaadin-compatibility-client not osgi compatible

Hello All,

I am migrating my application from Vaadin version 7.7.16 to Vaadin version 8.8.2. I am using Vaadin compatibility feature for the migration.
While migrating I found that vaadin-compatibility-client jar is not OSGi compatible. This is the only jar which has been left as non-OSGi compatible.
Please elaborate why only this jar is not OSGi compatible.

Hi,

Thank you for pointing out this omission. I’ve created https://github.com/vaadin/framework/issues/11660 that you can subscribe to for future updates on the topic.