Vaadin 7.7.2 and location of Widgetset

I updated my project to Vaadin 7.7.2 and notice that the widgetset.gwt.xml is generated at a different position. It used to be in resources/com/eqs/lei/widgetset.gwt.xml and now is in resources/com/eqs/lei/com/eqs/lei/widgetset.gwt.xml
When I start my application it does not work:
Failed to load the widgetset: ./VAADIN/widgetsets/com.eqs.lei.LeiWidgetset/com.eqs.lei.LeiWidgetset.nocache.js?147461859828

Where is the problem?

Hi,

Who is generating the widget set? Is this a Maven project? Ivy project? Are you using Eclipse? Something else?

It is created by vaadin-maven-plugin, and I am using Eclipse

        <plugin>
            <groupId>com.vaadin</groupId>
            <artifactId>vaadin-maven-plugin</artifactId>
            <version>${vaadin.plugin.version}</version>
            <configuration>
                <extraJvmArgs>-Xmx512M -Xss1024k</extraJvmArgs>
                <webappDirectory>${basedir}/target/classes/VAADIN/widgetsets</webappDirectory>
                <draftCompile>false</draftCompile>
                <compileReport>false</compileReport>
                <style>OBF</style>
                <strict>true</strict>
            </configuration>
            <executions>
                <execution>
                    <goals>
                        <goal>update-theme</goal>
                        <goal>update-widgetset</goal>
                        <goal>compile</goal>
                        <goal>compile-theme</goal>
                    </goals>
                </execution>
            </executions>
        </plugin>

I see now, it seems to be a regression in the fix for a regression… :frowning:

Try 7.7.3, it should fix the issue

Thanks, it does fix the issue