(Vaadin 7.3.3) Some notification types stopped showing

Has somebody else experienced my issue where certain notification types stopped showing? In my case it’s the Notification.TYPE_TRAY_NOTIFICATION and the message that shows when a session has expired. I’ve dug deep into my code, and the command

Notification.show("Caption", message, Notification.TYPE_TRAY_NOTIFICATION); is executed “correctly” without any errors, but in the UI nothing happens. This has worked before and to the best of my knowledge our code has not changed since. Our .css has neither, we use 99% standard Runo.

Did anybody else experience this or must it be somewhere hidden in our code. Any clues are welcome.

Thanks in advance.

Is it possible that you call the Notification.show(…) from separate thread or before the UI is attached? In that case it is possible that it does not get reference to current Page object which is needed to show the notification.

 // from Notification.java:
public static void show(String caption, String description, Type type) {
        new Notification(caption, description, type).show(Page.getCurrent());
}

No, it’s called from the same thread, and way after the UI is attached:

Notification.show("Saved", "Data was saved",Notification.Type.HUMANIZED_MESSAGE); // Works Notification.show("Saved", "Data was saved",Notification.Type.TRAY_NOTIFICATION); // Doesn't work but it must be somewhere in my application. For newly created Vaadin applications it works. I just don’t have a clue anymore where to look. First thing that comes to mind is the stylesheet, but my .scss looks rather unimpressively like this:

@import "../runo/runo.scss";

@mixin purple {

  @include runo;
  /* Insert your theme rules here */  
  .v-caption-purple {
      font-weight: bold;
  }
 .v-textfield-align-right {
   text-align: right;
    }
}

Have you tried to remove your changes one-by-one and see which one is hiding the notifications? Do you have the issue in all browsers?

For anybody else who runs into this problem: Looks like in my case it was a problem of 7.3.3. I upgraded to 7.3.9 and everything is fine again. I also recompiled the theme, that also may have solved it.