Vaadin 7.0.5 and Maven archetype compilation fail

I am completely new in Vaadin world and try to use it with maven.
I have create my first Vaadin project using the archetype “vaadin-archetype-application” (7.0.5)
Archetype target completed fine.
Then I launch mvn:package (as sugest in the documentation : https://vaadin.com/book/vaadin7/-/page/getting-started.maven.html)

At the beginning all is working fine : goals “resources” and “update-widgetset” are executed successfully
But goal “compile” fail without any error message…
The last display message is about compiling “permutation”

Compiling 6 permutations
[INFO]
Compiling permutation 5…
[INFO]
Process output
[INFO]
Compiling
[INFO]
Compiling permutation 0…
[INFO]
Process output
[INFO]
Compiling
[INFO]
Compiling permutation 2…
[INFO]
Process output
[INFO]
Compiling
[INFO]
Compiling permutation 4…
[INFO]
Process output
[INFO]
Compiling
[INFO]
Compiling permutation 3…
[INFO]
Process output
[INFO]
Compiling
[INFO]
Compiling permutation 1…

And then, my pc (a mac in fact) froze completely… (I have to reboot)
This freeze is easily reproducible (each time I launch the compile goal in fact)
I have try to change the Xmx value → 1024 but without any luck!

Any idea ?
Something to do to set the maven Vaadin plugin more verbose ?

Thx for our help

Mathieu

I assume you used -Xmx1024M (don’t forget the “m” or “M”) and put it in the correct place inside the Vaadin plugin configuration, as it applies to a separate compilation process that the plugin starts.

Widgetset compilation is be very CPU and memory intensive, and could take a very long time if it causes your computer to swap. The computer can feel quite unresponsive if that happens.

That said, you could try to set logLevel as TRACE in your POM. It can produce a
lot
of output, though. You could also try to edit your .gwt.xml file to only compile one permutation (uncomment the part selecting the browsers to compile for) and see if it helps. If that works, you can set a low value (1 or 2) for the localWorkers parameter to make sure only one or two permutations are compiled in parallel.

Thank’s for your very quick answer.

Yes I use -Xmx1024M
I have just try to uncomment the line in my .gwt.xml file
And i have now a beautiful error message :
[ERROR]
Property ‘user.agent’ not found
[INFO]
[ERROR]
Failure while parsing XML

I have certainly missed something :frowning: