Vaadin 6 communication errors

We have a number of applications using Vaadin 6 and recently have been getting feedback from users of a increase in communication errors.
I know they need to be upgraded but the client has not approved it yet.
Question is if the users are using the more current versions of browsers that Vaadin 6 doesn’t officially support, could that result in a increase of communication errors?
Any feedback or suggestions would be greatlt appreciated, thanks!

Yes, this could be related. We haven’t been systematically testing Vaadin 6 against newest browsers. Actually the first framework version that properly addresses this issue is Vaadin 7.6.

Thanks for the reply and information, greatly appreciated.