Vaadin 6.2.4 available

Vaadin 6.2.4 was pushed out yesterday; the Maven update had some trouble and is still to be done.

This is a maintenance release for Vaadin 6. If you are developing Portlet 2.0 applications, notice that an API feature added in 6.2.1 was reverted because it caused trouble. See the
Release Notes for Vaadin 6.2.4
for more information.

Get the installation package from the download site at
http://vaadin.com/download
. If you are using the Vaadin Plugin for Eclipse, upgrade the Vaadin version from the project preferences.

Problem fixes and enhancements planned for upcoming releases can be found from the
Vaadin Roadmap
in Vaadin Trac.

As always, when upgrading from an earlier version, you should recompile any custom widget sets and refresh your project in Eclipse. If you are upgrading from earlier than 6.1.0, notice that Vaadin 6.2 uses GWT 1.7 (included in the installation package). See the
General Upgrade Notes
for more details on upgrading.