Vaadin 24: Trying to run designer in eclipse, fails with NPE.

Hi, I’ve entered a 2 week trial for Flow, and wanted to look into this version - been working with vaadin 7 and 8. However it fails to startup when clicking on the .ts file. The following null pointer exception is thrown:

java.lang.NullPointerException: Cannot invoke “com.vaadin.designer2.services.flow.PackageJson.getDevDependencies()” because “packageJsonObj” is null
at com.vaadin.designer2.services.flow.PackageJsonUtil.addDevDependencies(PackageJsonUtil.java:45)
at com.vaadin.designer2.services.theme.AbstractThemeService.addFrontendDeps(AbstractThemeService.java:418)
at com.vaadin.designer2.eclipse.editors.flow.Polymer3FlowEditor.init(Polymer3FlowEditor.java:71)
at org.eclipse.ui.internal.EditorReference.initialize(EditorReference.java:353)

any tips on how to launch the Designer in Eclipse…?
My eclipse is: Version: 2023-06 (4.28.0) and it runs flow apps just fine.

Hi, at first I also had this problem. May be you take a wrong example.
Try https://vaadin.com/docs/latest/tools/designer/getting-started/setting-up-your-environment “Download Starter”