Vaadin 24.1.7 can be deployed on wildfly, 8 and 10 and 12 don't.

Hi Guys, I updated my app from Vaadin 24.1.4 to 24.1.10 (and spring boot 3.1.2 to 3.1.4) and got a problem with deployment on wildfly. Tested wnd found 24.1.7 is still working, 24.1.8 not. Error message : Failed to execute goal org.wildfly.plugins:wildfly-maven-plugin:2.0.2.Final:deploy-only (default-cli) on project reden2: Failed to execute goal deploy-only: {“WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:” => {“Operation step-1” => {“WFLYCTL0080: Failed services” => {“jboss.deployment.unit."reden2.war".component."jakarta.servlet.http.HttpServlet$NoBodyAsyncContextListener".WeldInstantiator” => "Failed to start service

[ERROR] Caused by: org.jboss.weld.resources.spi.ResourceLoadingException: Error while loading class jakarta.servlet.http.HttpServlet$NoBodyAsyncContextListener

[ERROR] Caused by: java.lang.IncompatibleClassChangeError: jakarta.servlet.http.HttpServlet and jakarta.servlet.http.HttpServlet$NoBodyAsyncContextListener disagree on InnerClasses attribute"}}}}

Maybe this is related to “Vaadin 24 overrides my webservices”. Whatever you guys changed from 7 to 8 is there any chance that you have an idea on how to fix it on my side or yours? Have a nice day!

Just to check if the issue is caused by Vaadin, can you try to run with Vaadin 24.1.10 and Spring Boot 3.1.2?

I did this, same problem.

(Spring boot was my first suspect, but it was not guilty^^.)

(My tests then went : 3.1.4 / 24.1.4 (working) , 3.1.4/24.1.6 (working), 3.1.4/24.1.8 (not working), 3.1.4/24.1.7 (working)).

Can’t see any notable changes between 24.1.8 and 24.1.7. apart from a Sring Boot bump from 3.1.2 to 3.1.3 :thinking:

BTW, which Wildfly version are you using?

That’s wildfly 29.0.0 . I will have a look if that one is updatable maybe.

Yes it is - we will do that and I will tell you the result lateron. Thank you allready!

Sorry it took a while but now the wildfly is updated to version 29.0.1 and still the same problem with 24.1.8, 24.1.10, 24.1.12 .

Vaadin 24.1.7 can be deployed on wildfly, 8 and 10 and 12 don’t.

I tried the skeleton-starter-flow-cdi project with Wildfly 29.0.1 with Vaadin 24.1.12 and it works fine

Did you also upgrade the wildfly-maven-plugin? 2.0.2 seems quite old
I used 4.2.0.Final

Another thing you can check is if you have a dependency (direct or transitive) to servlet API with compile scope instead of provided

Probably related to this Problem upgrading Vaadin 24.1.4 to 24.1.11 · Issue #17773 · vaadin/flow · GitHub

Thank you! I will keep an eye on that one.