Vaadin 24.0.3 won't start

Hello,

I tried to upgrade a project to latest version, worked fine until I deleted

  • package-lock.json
  • package.json
  • tsconfig.json
  • types.d.ts
  • vite.config.ts
  • vite.generated.ts
  • node_modules

After that I’ve (re)build the project, all those files were (re)generated but it won’t start ! But if I take the war file and deploy it in external tomcat works !

Also the node_modules just disappears(as you can see in the video)

The full error log : https://pastebin.com/2irAvyaP

Thank you !

In the log: Failed to find the following css files in the node_modules or /home/spectral369/git/PDV_birotica/./frontend directory tree:
- tippy.js/dist/tippy.css
- print-js/dist/print.css
Check that they exist or are installed. If you use a custom directory for your resource files instead of the default frontend folder then make sure it’s correctly configured (e.g. set ‘vaadin.frontend.frontend.folder’ property)

As alternative to the new bundling mode, you could try the old / vite way of things with

“vaadin.frontend.hotdeploy=true”

“vaadin.frontend.hotdeploy=true” works
Idk what are those, they may be from previous vaadin versions
I upgraded this from vaadin 8 → 14-> 18-> ~20…

I will delete this post tomorrow

thank you very much !

Those are probably dependencies from an addon you are using or used within a NpmPackage annotation (don’t deleted this, this could be interesting for the devs, especially the log)

OK, but I will still delete the video after some time !
thank you for your help :slightly_smiling_face: