vaadin 23.3.24 startup warning

Upgrade to vaadin 23.3.24 and get this warning on startup message:

Vaadin depends on Atmosphere 2.7.3.slf4jvaadin5 but version 2.7.3.slf4jvaadin4 was found. This might cause compatibility problems if push is used.

Check your dependencies and see if one of them is importing the old atmosphere version.
mvn dependency:tree -Dverbose could help to identify the issue

conflict with hilla 1.3.24
image.png

hilla should update same version with Vaadin

Add an exclusion for atmosphere-runtime in Hilla dependency

it is possible to remove hilla ? I don’t use it anyway.
<hilla.version>1.3.24</hilla.version>

If you don’t use Hilla you can safely remove it

okay. thanks