Vaadin 23.2.0 NodeJS requirement

So 23.2.0 requires Node v16.17+
I had v16.14 installed but thought I was smart going for Node v18. However while everything seems to compile and webserver starts I cannot load the web app in my browser. I think I had the same problem earlier when I tried Node 17 something. At the time v16.14 was available and I could load the application. Must I use latest Node v16.17+ or should I be able to use v17 or 18 as well?

Node 17 and 18 should work also. What is the problem you experience?

Node 18 will become the LTS pretty soon and we will move to that

I get av browser console referenceerror: module not defined at index.js?v=5788e439:3

I am upgrading from V23.1.7

I will try 16.17 since v16 seemed to work last time while v17 had some of the same problems as now.

Yep. Same as last time. It loads successfully with Node v16