Vaadin 14 to 23 upgrade problem

Hello everybody. It’s my 1st topic, do not judge strictly pls.
I have strange issue after migration to v23.
I have no errors during mvn install, but when I run application UI isn’t rendered. I have almost blank page. Only H1(“Login form”) is rendered
I even tried to use simple LoginForm - still blank page.

I focused on login page, but problem affects whole app.

dependency changes:
java - 11
vaadin - 14.8.4 → 23.3.6
spring-boot 2.6.6 → 2.7.0
spring - 5.3.18 → 5.3.20

what I did:

  1. Deleted node_modules, package-lock.json, webpack.generated.js, webpack.config.js
  2. permitAll “/offline-stub.html”, “/sw-runtime-resources-precache.js”
  3. vaadin.useDeprecatedV14Bootstrapping=true
  4. mvn -C clean install package -Pproduction

Thank you for your attention!
image.png
image.png
image.png

vaadin_run_log.txt (12 KB)

Why did you do “3)”?

The vaadin-login-form might be undefined because of an error. Do you have a JavaScript error?

I don’t know how you secured the vaadin 14 app ( spring security) but you might have some changes to do ( I recommend to use the Vaadin Spring security class added in Vaadin 23)

Did you go over https://vaadin.com/docs/latest/upgrading/essential-steps?

yes, sure

it was in https://vaadin.com/docs/latest/upgrading/essential-steps?

yes, spring security. i’ve tried to disable it adding permitAll for any route. doesn’t help(

where should i see such error? i have no errors during mvn install and in browser console (only one about devtools)

In the browser console usually

You can replace your own security configuration to this: Enabling Security | Security | Vaadin Docs

same result :frowning_with_open_mouth:
image.png

Check what’s going on in the network tab, are some requests getting blocked?

looks ok.
image.png

Looks like it’s loading the index.html, but nothing else side from that. Double check this section for bootstrapping-related things: https://vaadin.com/docs/latest/upgrading/recommended-changes/#bootstrapping-changes

It says: It’s also possible to continue using the bootstrapping mode in V10-14 with the useDeprecatedV14Bootstrapping flag. Does it guarantees that ui will be rendered?

Ah in v10-14 … My bad

I believe it means “…from v10-14”

Thank you all for help!
I’ve deleted useDeprecatedV14Bootstrapping flag, changed security config, and deleted @Viewport from my mainLayout. now UI is generated.
it looks a bit different. but that is not big deal.

For some reason I have NPE in my view. It has Grid and update form. for some reason binder runs validation when I open this view. but i didn’t choose row in a grid. I suppose there were some changes in selection model because its ok on v14.
NPE.log (12.9 KB)