V 23.2.2 theme problem

any help with this error message after reload my app and still loading page without showing nothing :
NotSupportedError: Failed to execute ‘define’ on ‘CustomElementRegistry’: the name “vaadin-material-styles” has already been used with this registry

Sounds like you have inconsistent versions in your project. For example, that some components are from version 23.1 and others from version 23.2.

The bug was reported here; if you wanna follow it https://github.com/vaadin/flow/issues/14710

delete bundles folder from node_modules helps, now it works ok!

I have the same problem with vaadin 22, DOMException: Failed to execute ‘define’ on ‘CustomElementRegistry’: the name “vaadin-lumo-styles” has already been used with this registry, when I run the command npx find-duplicate-dependencies I got a lot of duplicated dependencies, I run mvn clean an compile I deleted the node_modules, but the error is still there.

unknown.png