Updating Vaddin from 24.2.3 to 24.3.3 Errors

Hey been attempting to update vaadin and i am running into some errors CSS errors and an error in a typescript

I checked my CSS files and they are all valid the typescript file is default from @vaadin-component-factory here are the errors https://pastebin.com/wKk48VaE

vcf-nav is not compatible and should be replaced with the official sidenav component.

Didnt know they added it as a component :smile: thanks for the help!

Documented here too: This component is not compatible with Vaadin 24.3 · Issue #33 · vaadin/vcf-nav · GitHub