Unable to resolve reference $vaadinvaadin-development-mode-detector

Hi, I have changed my development machine and get npm related errors, on multiple projects when trying to build… It seems like the root cause is the one stated above but I have not been able to resolev it …

Try deleting your node_modules if you have that and rebuilding.

If that doesn’t work, please share some more info about your project:

  • Vaadin version
  • Stack (spring boot?)
  • Java and Node versions

I have tried deleting node_modules and rebuilding which didn’t work. It seemed like uninstalling npm from my system solved the problem, because i figured node installed in the .vaadin folder somehow conflicted with the npm installed locally. I don’t if this was the issue, but it salved the problem. Any experiences with this ?

It sounds very similar to this issue another user was having last week vaadin-maven-plugin fails with NoSuchMethodError when trying to delete an outdated node version · Issue #135 · vaadin/maven-plugin · GitHub