UIDL could not be read from server - after deploying it on tomcat

Dear all,

i´m not sure if it is a problem in my application or with tomcat. If i run the application on my local tomcat, everything works like charm. The war is deployed in the webapps folder and i can access it without a problem.
I tried to deploy it on my hoster and the war file is not put inside the webapps folder. Instead i have a folder called “domains” in the tomcat directory and there is my war file deployed.
If i try to access the application i always get the “Authentication problem. UILD could not be read from the server. Check your servlet mappings. Error Code: 404”. I understand that there´s a problem with the web.xml but i have no clue how i can solve it. I tried stuff like “/VAADIN/" and "/nameofthedomain/” but if i change the url i cannot access the application anymore.
Maybe someone can give me a hint on what parameters i could check or where i have to change something.

Thanks in advance.


Can you get any other (non-Vaadin) servlet application running there? I know you understand that this isn’t a Vaadin problem – am just hoping to narrow down the issue. If you can get any simple “Hello World” type of servlet running there, then please post the web.xml file for that app and the Vaadin app and we may be able to solve the issue.


Hi Bobby,

thanks for your response. I tried the following: I created a new Vaadin Project in Eclipse. Deployed it on my local tomcat and everything worked as expected. I deployed it on the hosters tomcat and i get the same error.
Here´s my web.xml:

<?xml version="1.0" encoding="UTF-8"?> test Vaadin production mode productionMode false Test Application com.vaadin.terminal.gwt.server.ApplicationServlet Vaadin application class to start application com.example.test.TestApplication Test Application /* index.html index.htm index.jsp default.html default.htm default.jsp

I think the problem is the url-pattern since the project is not deployed inside the webapps folder. As I already said, it is deployed in a “domain” folder. I don´t know if there´s something i can change at the web.xml file or if i have to change some tomcat settings.

Hope you can help me.

Thanks in advance.


Ok, i still have no clue whats going wrong but I changed the hosting company and now everything works like charm.


Ha! That’s great news; sorry I didn’t get to help before you got this working. Generally speaking, your application should be packaged in a war file (that’s not technically a requirement, but it helps keep things together). That war file should contain, at the top level, a
directory (and
dir if you’ve added your own theme). That WEB-INF dir contains web.xml, a
directory, and a

You could also have other files at the top-level dir like HTML or JSP pages, but if you’re running your Vaadin app at /* then you probably won’t have anything else in there. That means you don’t need the information.

Given the above layout, it should work on any servlet container, so I’m not sure what you mean about a webapps folder or a domain folder. Possibly the ‘domain’ one is used in an app server like GlassFish, in which case you deploy the app through a tool or by copying to a certain directory, e.g. domains/domain1/autodeploy. So I’m guessing it’s just a deployment issue, as your app looks fine from what I can see.


Hello Jens

I suddenly started to have similar problem in mochahost. Was that your host provider also?

I am having the same problem with Mochahost - it started after some downtime with the servers.

Anyone who has any clue as to what they could be doing wrong?

Just another thought. What is the new provider that you are using . I am looking for alternatives, but they are hard to find for Java containers.

I just had the same problem at a hosting provider I’m trying out. They fixed it for me.

They have an Apache web server in front of the Tomcat servlet container. Apache didn’t direct all relevant calls to Tomcat - an Apache configuration problem.


Hello Einari,

Did you/they (mochahost) already solve the issue? I’ve got the same problem.

Hi Jens, I’m having the same problem with MochaHost. Which hosting company did you switch to? Thanks!

For those of you who were having this problem with MochaHost, was the problem fixed? Or you just moved to another hosting company? If so, which hosting company did you move to? Thanks!