Timeline questions

Hi,

A couple of questions about the Timeline object.

I am creating a graph by reading a set of data using the rrdtool program - we are
collecting data and storing it using RRD files. So for example, the current time
is 9:05 EDT (or 13:05PM GMT). I asked for data going back 4 days. The data collected
looks like this (first 10 and last 10 data points):


*** CREATE GRAPH SOURCE ***
	Start Time: -4 days
	Stop Time : now
Cmd: FETCH <path_to_rrd_file>/In_bps.rrd MAX 1346677548 1347023148

	Graph contains 5748 data points
0) 09/03/2012   13:06:00	::	582.598178504
1) 09/03/2012   13:07:00	::	555.221783832
2) 09/03/2012   13:08:00	::	620.75781544
3) 09/03/2012   13:09:00	::	633.361958568
4) 09/03/2012   13:10:00	::	577.11527276
5) 09/03/2012   13:11:00	::	674.569363656
6) 09/03/2012   13:12:00	::	557.70589544
7) 09/03/2012   13:13:00	::	540.46353872
8) 09/03/2012   13:14:00	::	584.64084468
9) 09/03/2012   13:15:00	::	567.363526904
	...	...	...
5738) 09/07/2012   12:55:00	::	567.2
5739) 09/07/2012   12:56:00	::	605.87322404
5740) 09/07/2012   12:57:00	::	597.912086688
5741) 09/07/2012   12:58:00	::	573.859133712
5742) 09/07/2012   12:59:00	::	544.42331512
5743) 09/07/2012   13:00:00	::	519.489302584
5744) 09/07/2012   13:01:00	::	542.510697416
5745) 09/07/2012   13:02:00	::	574.865573768
5746) 09/07/2012   13:03:00	::	562.853333336
5747) 09/07/2012   13:04:00	::	547.31841808

It looks to me like the data is exactly what I want.

When I put this into a timeline object, I create a BeanItemContainer, add these data
points, and it shows me a very nice graph. However, the start/stop times in the top
right corner of the graph show:

09/03/12 08:42-09/07/12 09:27

The times appear to be using the local time zone. I would prefer they show
UTC (GMT) but I’m not sure how to force that - can someone tell me??

I tried setting a ‘DateFormatInfo’ object to format the start/stop time info.
I used 'setDateSelectDisplaySimpleDateFormat(“MM/dd/yy HH:mm”)
I tried adding a ‘z’ at the end of the format, but that only added a (UTC-4) to
the time, and unfortunately, doesn’t really show the UTC part at all - it
gets truncated - not sure how to widen the space used to show the start/stop times… ??

Also, it looks like the start/stop times have a bit of a buffer around the actual
data points - am I interpretting that correctly? Is it always a flat 20 minutes
before the first data point and after the last or is there some other calculation
going on?

Thanks,

nbc