Table paging automatically re-enabled

Hi all,

I’ve got a table that contains an acceptable number of rows, so that I want to disable the lazy loading mechanism. I’ve done this using

setPageLength(0);

This works fine, except that when I click on a column header to sort the rows, paging is automatically re-enabled after the sorting is done.

Is this a bug or a desired behavior? And how can I permanently disable paging?

Hi!

Sorting shouldn’t have any effect to the height of the table. Do you set a fixed height for the table some where in your code because that can make setPageLength(0) ineffective. Could you please show us some more code of your table?