Table layout problems

Hi everybody,

how can i change the border around my table items?!

i try to add a border untder the last table item.

no css pros here ?! :smiley:

Try this:

.v-table-row-even:last-child td,
.v-table-row-odd:last-child td {
border-bottom: 1px solid gray;

hmm in my other tables the css code works…

but not in this one.

i´ll add some code so you can test it by yourself. ok?

edit: after edding the second item it works correct. but after adding the third the line disappears… and so on (attachement)

Oh, I forgot there was no such selector as v-table-row-even, only the odd one. So the following CSS should be correct:

.v-table-row:last-child td,
.v-table-row-odd:last-child td {
border-bottom: 1px solid gray;

ahh great :smiley:

thank you now its ok

and is there maybe a way to disable the resize function of the table columns?

Sorry, I don’t think there is currently a way to do that.

Planning/prototyping for the a new Table component is starting during these weeks, so you could make sure this functionality is on the list of features to consider. You can search the tickets in and if not found, report a new enhancement for it.

If you can afford to lose the small gray borders between the Table’s header cells, you can just set the following CSS which will hide the column resizer elements (and effectively prevent resizing):

.v-table-resizer {
   visibility: hidden;

I guess you might even find a CSS trick to add the borders properly back if you try :slight_smile:


Ah, of course. Neat trick.

hmm ok.

i´ve tried to add columnResizeListener which is setting the column size to the default value.

it is not the best solution but it works