Table displays thin line for selected item after Container change

I have a table, which is selectable. The user can click the usual Add, Edit, Delete buttons.

If they click Add or Edit a form is opened up for the selected item. Once they click “Save” they are returned to the list view.

If the values are saved, then the Container Data Source is set again. [
I’ve not found a more elegant way of updating a single row than this

However, all of this has been working fine. The underlying code has largely been untouched for months.

However today, I was changing the base theme for my custom theme (which makes no CSS changes, it’s there to load images only at this time). I tried changing from Runo which I’d been using, to Reindeer and back a few times, trying different things.

What happens now, is that:

  1. User selects table item
  2. Clicks Edit & form pops up as expected
  3. On form close the Table now displays A THIN LINE with no values!!!

The actual data value is still there, Edit, etc. all still work- but the visual side of the table has become a thin line.

The only way to change this, is to refresh the whole page- by clicking on another tab and then back to the original one, which causes the Data Source Container to be re-applied (again) but this time the display is correct UNTIL the user edits a line again.

Changed back to Runo, same issue, happens with any theme setting.

I hope this make some sense- it is 100% repeatable but I have no idea what I’ve done to cause this change, any pointers would be very welcome.
Thanks in advance,


I recognized the same thin line after updating to Vaadin 6.8.2 without any changes on my source code. But I didn’t do further investigations yet.


Thanks for confirming my observation.

For a moment there I thought you might have solved it for me, but I just tried downgrading to Vaadin 6.7.9 and up to Vaadin 6.8.8 - same issue all round.

I have found the problem happens if your table has a table factory. If you remove it, then the problem seems to go away.