StreamResource not calling getStream()

Hi there - I am trying to load an image from a byte, at this point simply hardcoding the data. My colleague and I have run this identical snippet in two different environments, but his displays the image and mine only displays the “name” of the Embedded element. I have added variations I’ve tried into the comments. For some reason, the getStream() method overridden in the StreamResource.StreamSource never gets run in mine. (Pardon

Any help would be greatly appreciated!

StreamResource.StreamSource imageSource = new StreamResource.StreamSource() {
                @Override
                public InputStream getStream() {
                    byte[] buf = DatatypeConverter.parseHexBinary("[rawdata]
");  // this data has been truncated for the post, but is confirmed to be accurate
                    return new ByteArrayInputStream(buf);
                }
            };


            StreamResource imageResource = new StreamResource(imageSource,"test.png", getWindow().getApplication());      // have also tried just 'getApplication()' here
            imageResource.setCacheTime(0);
            Embedded image = new Embedded("monkey", imageResource);
            image.setType(Embedded.TYPE_IMAGE);                // have tried image, object and NO type
            image.requestRepaint();
            
            addComponent(image);

Additional note: It appears that this problem may be narrowed down to the getApplication() call. We have an “embeddedApp” that extends Application and it seems to stem from that extra level. Is there a way to find the proper call to reach the true parent application?