soycReport folder missing from final war file

Hello, I’ve been checking on creation of widgetsets with Vaadin and TouchKit. While aparently harmless i’ve been receiving error that state that any file of that path can’t be found. While the folder and files are generated on the target directory with the maven plugin, at the end the folder is not added to the final war file.

Any suggestions?

Thanks for your help.

Normally, soycReport should not be in the WAR.

It is sometimes useful for debugging client side code of GWT applications and the GWT compilation process, but for Vaadin applications I’d say you don’t need it in practice and it would just unnecessarily bloat the WAR.

Thanks for the answer. I suppose that there must be some flag in the widgetset xml to disable the recurrent petition of files from soycReport because it’s something i’ve never seen when using 3rd party widgets.

Hello - we’ve just started using Touchkit, and are seeing that error. Any word on how to get widgetset to stop looking for it?:


Application Cache Error event: Resource fetch failed (404)
http://localhost:8080/vaadin/VAADIN/widgetsets/com.ideas.tetris.ui.widget.TetrisMobileWidgetset/soycReport/compile-report/fragment1_null-1Lits.html

Looks related to GWT and code-splitting, as soyc<…> resources get requested in manifest:

/VAADIN/widgetsets/MobileWidgetset/safari.manifest

Contents:

soycReport/compile-report/SoycDashboard-0-index.html soycReport/compile-report/SoycDashboard-1-index.html soycReport/compile-report/SoycDashboard-2-index.html
.
.

Anybody know how to alter widgetset to stop adding soycReport/ elements to manifest?

Hi,

My guess is that you don’t actually nedd the soyc report at all. You can remove it by adding this config to your vaadin maven plugin:

<compileReport>false</compileReport>

cheers,
matti

Yep, you were right. Didn’t realize our widgetset pom got set up with that flag enabled. I’m guessing we originally copied from some online example :slight_smile:

Here’s the relevant bit, for reference:



com.vaadin
vaadin-maven-plugin

false

Yep, it used to be on in our project archetype. Bad default, that got fixed a while ago.

cheers,
matti