Required Node version

From Vaadin Flow’s changelog (https://github.com/vaadin/flow/releases) Vaadin 24 should be the first version to require Node 18. However, when I upgraded from Vaadin 23.2.4 to 23.3.6, Node was already upgraded from v16.17.1 to v18.13.0. Does Vaadin 23.3.6 really need Node 18 or should it still work with 16?

It’s only upgraded if you don’t supply your own node / Vaadin finds something in .vaadin

Vaadin 23.x still works with Nodejs 16.x

Setting the node.auto.update property to false also works (if Node 18 wasn’t downloaded already). But we really need to update our Jenkins machine, if it can’t run Node 18…