Push not working in samsung browser (S3)

Hi,

I opened http://demo.vaadin.com/pushblog/ demo with build-in browser of s3 mobile device and it seems push is not working. It displays “Fetching from database” and then nothing else happens. Also tried with an own small push apllication, with same result. Chrome is just fine.

It seems to be vaadin implementation specific as other frameworks work well with push on this browser, e.g. http://livedemo.exadel.com/richfaces-demo/richfaces/push.jsf

Any hint how to get this work on samsung standard browser with vaadin?

Best regards,
Rudolf

That demo is running on a beta version of Vaadin 7.1 - did you also try the final release version?

According to a quick look with an S3 simulator, it seems there might indeed be problems. After automatically switching from websockets to the fallback transport (streaming), no further events were received.

Please
create a ticket
about this.

Thanks, indeed it works now after changing to final 7.1., I accidentally was working with beta1 in this project.