Production Mode=True

Hi Iam using Vaadin 7.5.6
and my web.xml contains the following

Vaadin production mode productionMode true

and my POM.xml contains the following

    <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-clean-plugin</artifactId>
            <version>2.6.1</version>
            <configuration>
                <filesets>
                    <fileset>
                        <directory>src/main/webapp/VAADIN/themes</directory>
                        <includes>
                            <include>**/styles.css</include>
                            <include>**/styles.scss.cache</include>
                        </includes>
                    </fileset>
                </filesets>
            </configuration>
        </plugin>

        <plugin>
            <groupId>org.codehaus.mojo</groupId>
            <artifactId>exec-maven-plugin</artifactId>
            <version>1.2.1</version>
            <executions>
                <execution>
                    <!-- <phase>generate-sources</phase> -->
                    <goals>
                        <goal>java</goal>
                    </goals>
                    <configuration>
                        <classpathScope>compile</classpathScope>
                        <mainClass>com.vaadin.sass.SassCompiler</mainClass>
                        <arguments>
                            <argument>src/main/webapp/VAADIN/themes/vegatheme/styles.scss</argument>
                            <argument>src/main/webapp/VAADIN/themes/vegatheme/styles.css</argument>
                        </arguments>
                    </configuration>
                </execution>
            </executions>
        </plugin>

but i am getting the following error

Apr 13, 2016 4:48:49 PM com.vaadin.server.VaadinServlet serveOnTheFlyCompiledScss
INFO: Request for /VAADIN/themes/vegatheme/styles.css not handled by sass compiler while in production mode

Thanks
Nagaraj

This has been discussed previously:



https://vaadin.com/forum#!/thread/2336811

Hope this helps!

All the best,
–Enver

I done the same thing as provided in the link you given u can see in second plugin which i shown above but still i am getting the same problem .
do i need to add depency of ‘exec-maven-plugin’ in my dependency section.

Thanks
Nagaraj