Problem With Vaadin Starter With Security Deployment On Tomcat 10.

i have 2 base vaadin starter from https://start.vaadin.com/app, one with security and one without it. test it with IDE environment it run smoothly, and then i tried to deploy both on local tomcat 10 server(i changed it to war first) the one without security run fine, the one with security is not.
i check the catalina.log i found these but im not sure how should i fix the problem, please help
message.txt (4.94 KB)

Are you accidentally running the Tomcat with an older JDK than 17?

because “lookup” is null

This typically indicates that the startup listeners defined in Flow were not run. The reasons can be many different

The other would be that you have not added extends SpringBootServletInitializer, see e.g. https://www.baeldung.com/spring-boot-war-tomcat-deploy

i already added these, im not sure about the JDK though i checked my environment var i already set it to jdk 17

i think you right it might be the problem
image.png

already set it to 17 but still get the same error on the catalina.log
image.png

The other thing that comes to mind is https://github.com/vaadin/flow/issues/16236

But nobody has reported it for anything else than tests

seems like it’s in “good to go” tag, does that means the fixes already implemented in this current vaadin patch, or in the next update ?

There is a PR waiting to be merged: https://github.com/vaadin/flow/pull/16472

okay then, thank you