Problem with run application

Hi, I download flow-crm-tutorial project and my intelliJ don’t work correctly (this is my thought). I can’t run main method (error /Library/Java/JavaVirtualMachines/jdk-19.0.1/bin/java: cannot execute binary file). I learn on apple’s silicon. Thanks for your help.

Sounds like your Java installation is for the wrong architecture. If you run ”java” in a terminal you probably get the same error

michal@MacBook-Pro-Michal ~ % javac TestMyJava.java
error: file not found: TestMyJava.java
Usage: javac
use --help for a list of possible options
michal@MacBook-Pro-Michal ~ %

michal@MacBook-Pro-Michal ~ % javac --version
javac 19.0.1

michal@MacBook-Pro-Michal ~ % java --version
java 19.0.1 2022-10-18
Java™ SE Runtime Environment (build 19.0.1+10-21)
Java HotSpot™ 64-Bit Server VM (build 19.0.1+10-21, mixed mode, sharing)

is that /Library/Java/JavaVirtualMachines/jdk-19.0.1/bin/java ?

yes

I think about reinstall my java

also I have sometimes notification about update my java

and this update every time is going with error

I don’t learn on this notebook since few month and know I must resolve some problems :sweat_smile:

So, I was having 5 versions of java, I was deleting all version in folder /Library/Java/JavaVirtualMachines/ . Now I have java 17 with was in my system (mac os). Now I have some issues with library, I added this library from maven repository org.springframework.data … but compilator still don’t see this and when I run mvnm file I have error on my browser.

Is it normal that I must manually add library?

I resolve this problem :wink: