Prevent Table fromjumping to top

Hi there,
we’re currently having an issue with the Table component, I’m hoping you’ll be able to help.
We have a Table that receives lots of value updates (~ one update every 2-5 seconds) and the occasional insert and remove. We’re using Dontpush for the client-server connection and the load is not a problem, all updates are displayed in a second or less.

There is just one tiny issue: with every update, the table jumps back to the top. It’s impossible to scroll down and do anything, because with the next update two seconds later the table jumps back. Is there any way to disable this behaviour and just leave the table scrolled to the same position as before? I really need the table not to move at all on updates - optimally, it wouldn’t move on inserts and removes, either.

Is there any way to achieve that behaviour?

Thanks for your help!

Sorry, there is a small error in my post: the component doing this is not a Table, it is a TreeTable.
I thought initially that all tables were affected, but subsequent testing has shown that only TreeTables are jumping.