Popup window (subwindow) not displaying and not modal

I have a complex situation so I’m going to simplify it a bit and then add detail if I need to. I’m using version 6.8.3.

Basically, I have a “popup” window (a subwindow in modal mode) that sometimes does not display and is not modal. Here’s the setup:

I have a tabbed control with tabs that display mostly grids. One tab is a form that validates two dates and then calls a popup window to ask “are you sure” and if they are, it starts processing. When the previous tab has been a simple grid the popup works fine. But if the previous tab has been a more complex window, the popup get “lost”. It doesn’t display and my form can still get events from the mouse and keyboard.

When I try to put the window in debug mode, my application gets an endless loop of exceptions. The interesting thing is that if I’ve pressed the OK button threes times (this is the event that should display the popup) three popup windows “unhide” before I have to shutdown the app. It’s as if they have rendered “behind” another window or something. I don’t know if that helps.

I can describe the the “more complex window” if that would help. It is possible that I am doing something wrong in how I set them up.

This is a critical project for my company. Any help is appreciated.

  1. What kind of Exceptions are you getting when the Window is in debug-mode?
  2. Have you tried using Firefox (or similar tooling) to check whether the Window gets actually rendered?
  3. Are you using a custom theme? If yes, try to use RUNO.

I was able to debug without an error. This appears to be the popup window that’s not displaying:

JSON parsing took 0ms
-Response:
-change format=uidl pid=PID0
-com.vaadin.terminal.gwt.client.ui.VWindow id=PID0 height=575px width=1180px caption=Demand Planning Tool name=menu theme=dpttheme resizable=true main=true layoutRelativeHeight=true layoutRelativeWidth=true
+variables
-com.vaadin.terminal.gwt.client.ui.VVerticalLayout id=PID1 cached=true
-org.vaadin.csstools.client.VRenderInfoFetcher id=PID437 cached=true
-org.vaadin.csstools.client.VRenderInfoFetcher id=PID440 cached=true
-com.vaadin.terminal.gwt.client.ui.VWindow id=PID721 width=30.0% caption= name= theme=dpttheme modal=true resizable=true center=true layoutRelativeWidth=true sub=true
+variables
-com.vaadin.terminal.gwt.client.ui.VVerticalLayout id=PID722 width=100.0% margins=15 alignments={} expandRatios={}
-com.vaadin.terminal.gwt.client.ui.VLabel id=PID723 width=100.0%
Are you sure you want to create this new forecast?
-com.vaadin.terminal.gwt.client.ui.VHorizontalLayout id=PID724 margins=0 alignments={} expandRatios={}
-com.vaadin.terminal.gwt.client.ui.VButton id=PID725 caption=Yes
-variables
state=false
-com.vaadin.terminal.gwt.client.ui.VButton id=PID726 caption=No
-variables
state=false

Goggle dev tools says, "Uncaught TypeError: Cannot call method ‘create’ of undefined "

The following is what should be the popup window:

http://snortum.net/images/Vaadin_popup_window.png

No.

Is there anything else I should to test or investigate this? Any help would be appreciated.

So far, it does look right …

Some things I would check are: Are there Exceptions on the server-side (maybe swallowed ones?) Does the code that should display the popup run as expected?
Is the window-instance you are adding the dialog to, the correct one?
Are there any elements on the client-side that might have a greater z-value than the dialog-window?

At least the last point might be rather bizarre, but I have no clue so far what might cause this behavior…

As far as I know it does. I am just running this in a local Tomcat server from Eclipse, but the production JBoss server has the same problem.

Again, as far as I know. I have a form and I’m creating the subwindow off of that. There isn’t a way for the program to switch windows on me, is there?

I thought about this, but I don’t specify the z-value of any windows. Could the rendering engine get confused about what z-value a window has?