PasswordField mysteriously masks other PasswordField

I implemented a new user tab containing two PasswordFields and wrote a validator to verify that the passwords were identical, and that worked fine.

Then I added a new tab with a bit of copy pasting where an admin can change a user’s password, also containing two password fields and using a new instance of the same cross field validator to verify that the passwords are identical.

What happened when I introduced the new password change tab, was weird:

  1. The second password field from the first form disappeared
  2. The validator of the second form (the change password form) reported a mismatch even when the two passwords were identical

I have tried reverting the change, and that gave me the password field back in the new user tab (but of course no change password tab).
I have stared at the code to see if I could see some leftover unchanged variable names (ie. variable names that haven’t had the “newUser” prefix changed to “editUser”) but so far the new code looks correct to me.

All tips and hints are appreciated!

Some more details on the code:

At least in the commit “bae89783ffeb4ae6e2863394d9243afdeb4d272d” the line 424 has newUserPassword2Field instead of editUserPassword2Field

Thank you! :slight_smile:


it had to be a copy/paste error like this, I just couldn’t see it… thanks again!)