One browser works, the other says it failed to load ./VAADIN/vaadinBootstra

Platform: Windows 10, Vaadion 7.6.1, chrome 61.0.3163.100 (Offisiell delversjon) (64-bit), Vivaldi 1.12.955.36 (Stable channel) (32-bit)

Right now my application is in a state where vivaldi works, but on chrome all I get is a dialog box saying:
Failed to load the bootstrap javascript: ./VAADIN/vaadinBootstrap.js?v=7.6.1

The obvious culprit would seem to be caching in the browser.

However I have been unable in making chrome reload in a way that makes it work again (the same application worked earlier today).

I have tried forcing reload on chrome many types, pressed F12 and then right-clicked the reload icon, I have restarted chrome twice, and even upgraded chrome and it still fails.

Is this something others have seen or is this black magic?

Is there a foolproof way to force chrome to reload everything?

The application that fails, is: https://github.com/steinarb/ukelonn/tree/using-vaadin

Thanks!

  • Steinar

I’m nearly 100% certain the reason for the difference is browser caching.

Starting a fresh browser (e.g. starting a firefox) or opening a chrome incognito window both get a working application.

What I
don’t
know is how to force the browser to reload in a predictable manner. Flushing the cache and reloading isn’t enough.

Has anyone found a solution to this? I’m getting the same issue with Vaadin 8.3.3