New project issue: [WARNING] Error checking if npm is new enough

Hey there,
i want to start with Vaadin. Downloaded the project files generated by start.vaadin.com and opened this in IntelliJ.
When i use “mvn” to create a build or start the file directly from IntelliJ an erroror occurs. Im using Windows.

[WARNING]
 Error checking if npm is new enough
com.vaadin.flow.server.frontend.FrontendUtils$UnknownVersionException: Unable to detect ver
sion of npm. Using command C:\Users\Jonas\.vaadin\node\node.exe C:\Users\Jonas\.vaadin\node
\node_modules\npm\bin\npm-cli.js --no-update-notifier --no-audit --scripts-prepend-node-pat
h=true --version

Already tried:

  • Different Vaadin and Java versions
  • Reinstall NodeJS
  • Put the Project in a directory which can be accessed by a shorter path.

I would be very grateful for your help

Edit: I fixed this.
The npm_cli.js wasn’t working. Even if tried to access this file directly by the terminal.
I installed nodeJS separately and replaced the node files from .Vaddin with the ones created by the setup. Also switched to Vaadin v19

Hope this helps if someone has the same issue