MyEclipse IDE Compatibility

Has anyone installed the Vaadin Eclipse plug-in into a

MyEclipse IDE is a customised installation of Eclipse with a number of integrated J2EE development tools. Although it includes the standard Eclipse WTP functionality, much of it has been enhanced and some of it has been deprecated. Consequently, it may not appear that WTP is installed.

Although the Vaadin plug-in installs, the facet isn’t available and the new project wizard doesn’t appear.

For the moment, I’m going to work with two separate Eclipse installations. However, it would be great if the Vaadin plug-in could be made to install in MyEclipse.

BTW, I only discovered Vaadin a few hours ago by chance. Timing was perfect as I was just about to start investigating tools for portlet development for Liferay. Everything I’ve seen so far has been absolutely brilliant and the fact that my Eclipse environment is based around MyEclipse has been the only stumbling block so far.


Apparently you (?) were asking the same question here:
. Did you get it to work?

I just installed the plugin in MyEclipse 7.5 without problems. I went ahead and created a new Vaadin project and deployed it to a Tomcat server. Worked exactly like the standard Eclipse.

  • Artur

It was my posting on the MyEclipse forum but only indirectly related to Vaadin Eclipse plugin.

Purpose of the MyEclipse forum question was to attempt to resolve an error message in the Eclipse log during startup. I was only getting that message in my MyEclipse installation not in my standard Eclipse installation. Only noticed the message when attempting to determine why Vaadin Eclipse plug-in didn’t work in MyEclipse. However, the error message might have been there before and could be totally unrelated.

Appears that the error message may be something related to MyEclipse milestone release based on the last response on the MyEclipse forum:

In my MyEclipse installation (8.0M1) it appears that the Vaadin Eclipse facet is missing. MyEclipse hides/modifies the way the standard Eclipse WTP is installed. These features can be re-enabled but I’ve tried to avoid doing this as I suspect it might introduce some anomolies in future that will be beyond may capacity to resolve :frowning:

When you successfully installed into MyEclipse version 7.5, did you do any “tweaking” of the environment related to WTP?

I simply did

install → add Vaadin update site → install the plugin → restart → create new Vaadin project → deploy

and it worked like with the normal Eclipse. I don’t know anything about the 8.0M1 version so I cannot comment on that. Just tested the latest stable to see that the plugin worked.

Guess it’s a problem with the MyEclipse 8.0M1 release. I’ll post on the MyEclipse site. I don’t have 7.5 installed as I’m just getting back into web development and haven’t used MyEclipse for a couple of years. I’ll stick with the standard Eclipse install for my work with Vaadin.

Thanks for your input.